summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCosimo Cecchi <cosimoc@gnome.org>2013-01-25 14:34:14 -0500
committerCosimo Cecchi <cosimoc@gnome.org>2013-01-25 15:21:14 -0500
commit12596e2cd0585db73af54d4180065e001d01e67f (patch)
tree257cd10ed29fa80c9532c629da05a60b490f4763 /configure.ac
parent00194b55a5c93c63bb923673c1606c94fef73ab5 (diff)
downloadgnome-themes-standard-12596e2cd0585db73af54d4180065e001d01e67f.tar.gz
gtk2: make it possible to override GtkEntry's backgrounds
Some GTK2 applications like to override GtkEntry's background with their own color for e.g. showing an error state. Since we currently draw an asset for the entry's background, this doesn't work. To support this use case, always use the background color from the style with no overrides, and put an overlay on top of it to get the same gradient we used to get. In addition, entry borders cannot be transparent anymore now, so we have to provide two versions - a normal one and one that works on notebooks, to avoid the base shining through the corners. This also bumps the GTK2 required version to 2.24.15, which has a fix that makes this possible. https://bugzilla.gnome.org/show_bug.cgi?id=685712
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 17334537..89e76980 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,8 +59,9 @@ AC_MSG_CHECKING([building gtk2 engine])
AM_CONDITIONAL(GTK2_ENGINE, test "x$enable_gtk2_engine" = "xyes")
AC_MSG_RESULT([$enable_gtk2_engine])
+GTK2_VERSION_REQUIRED=2.24.15
if test "x$enable_gtk2_engine" = "xyes"; then
- PKG_CHECK_MODULES([GTK2_ENGINE], [gtk+-2.0 gdk-2.0])
+ PKG_CHECK_MODULES([GTK2_ENGINE], [gtk+-2.0 >= $GTK2_VERSION_REQUIRED gdk-2.0 >= $GTK2_VERSION_REQUIRED])
fi
GLIB_COMPILE_RESOURCES=`$PKG_CONFIG --variable glib_compile_resources gio-2.0`