summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build13
1 files changed, 3 insertions, 10 deletions
diff --git a/data/meson.build b/data/meson.build
index fcba7bb3..5c4fb507 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -16,17 +16,10 @@ schema_conf = configuration_data()
schema_conf.set('GETTEXT_PACKAGE', meson.project_name())
foreach schema: schemas
- schema_in = configure_file(
- input: schema + '.in.in',
- output: schema + '.in',
- configuration: schema_conf
- )
-
- custom_target(
- schema,
- input: schema_in,
+ configure_file(
+ input: schema + '.in',
output: schema,
- command: [intltool_merge, '-x', '-u', '--no-translations', '@INPUT@', '@OUTPUT@'],
+ configuration: schema_conf,
install: true,
install_dir: gsd_schemadir
)