summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2018-02-02 10:19:54 +0100
committerBastien Nocera <hadess@hadess.net>2018-02-05 17:42:49 +0100
commitf69e9d8c74a46b700d751ec93cd82a3699d6c497 (patch)
tree8dc01e925a36d4e34f1db57784462d59165d58f7 /data/meson.build
parent06c62bdefe3be5d366f539bdfc3a0aaf3bdcad67 (diff)
downloadgnome-settings-daemon-f69e9d8c74a46b700d751ec93cd82a3699d6c497.tar.gz
build: Migrate from Intltool to Gettext
Recent versions of Gettext are able to translate several formats that are used in GNOME applications. This patch migrates from Intltool to Gettext by using meson's i18n features. Explicit encoding has also been added to the gschema files due to an issue in gettext[0] with default encoding in XML files. https://bugzilla.gnome.org/show_bug.cgi?id=793087 [0] https://savannah.gnu.org/bugs/?52932
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build13
1 files changed, 3 insertions, 10 deletions
diff --git a/data/meson.build b/data/meson.build
index fcba7bb3..5c4fb507 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -16,17 +16,10 @@ schema_conf = configuration_data()
schema_conf.set('GETTEXT_PACKAGE', meson.project_name())
foreach schema: schemas
- schema_in = configure_file(
- input: schema + '.in.in',
- output: schema + '.in',
- configuration: schema_conf
- )
-
- custom_target(
- schema,
- input: schema_in,
+ configure_file(
+ input: schema + '.in',
output: schema,
- command: [intltool_merge, '-x', '-u', '--no-translations', '@INPUT@', '@OUTPUT@'],
+ configuration: schema_conf,
install: true,
install_dir: gsd_schemadir
)