summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBenjamin Berg <bberg@redhat.com>2020-01-22 14:33:25 +0100
committerBenjamin Berg <benjamin@sipsolutions.net>2020-07-31 08:53:12 +0000
commitecf12b3169fa64ddef392deb84a9cbb78746b0a2 (patch)
tree1ec53ef25e6529403635dc44848f10d4b795fee2 /meson.build
parente0dbfa275444c25f318a6f37cdb4f5264db74fe8 (diff)
downloadgnome-settings-daemon-ecf12b3169fa64ddef392deb84a9cbb78746b0a2.tar.gz
meson: Make usb-protection plugin build time configurable
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b6fc2ff6..d2b86b31 100644
--- a/meson.build
+++ b/meson.build
@@ -174,6 +174,8 @@ if enable_smartcard
endif
endif
+enable_usb_protection = get_option('usb-protection')
+
# CUPS
enable_cups = get_option('cups')
if enable_cups
@@ -261,6 +263,7 @@ output += ' cflags: ' + ' '.join(compiler_flags) + '\n\
output += ' ALSA support: ' + enable_alsa.to_string() + '\n'
output += ' NetworkManager support: ' + enable_network_manager.to_string() + '\n'
output += ' Smartcard support: ' + enable_smartcard.to_string() + '\n'
+output += ' USB Protection support: ' + enable_usb_protection.to_string() + '\n'
output += ' Cups support: ' + enable_cups.to_string() + '\n'
output += ' Wayland support: ' + enable_wayland.to_string() + '\n'
output += ' Wacom support: ' + enable_wacom.to_string() + '\n'