summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAaron Plattner <aplattner@nvidia.com>2019-12-04 16:18:41 -0800
committerCarlos Garnacho <carlosg@gnome.org>2021-01-11 21:27:59 +0100
commite90a75fd59ac41aa331f53492a84712e43bcbce2 (patch)
tree6f84426389dc35879f197a329a6bc31102cd3657 /meson.build
parentcdd42298d6c154f71fdb0a294b117877a4965551 (diff)
downloadgnome-settings-daemon-e90a75fd59ac41aa331f53492a84712e43bcbce2.tar.gz
Use the window system's color transform matrix, when available
When the window system supports color transform matrices, use libcolord to compute an adaptation matrix to convert from an sRGB reference profile to the measured profile for each display. Use gnome_rr_output_set_color_transform from libgnome-desktop to apply that matrix to the window system. Modify the code that sets the _ICC_PROFILE root window property to hard-code a standard sRGB reference profile when a color transform is in use; color-aware applications should not try to apply their own correction if the window system is already doing it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 7dbee64b..41378a5d 100644
--- a/meson.build
+++ b/meson.build
@@ -93,7 +93,7 @@ glib_dep = dependency('glib-2.0', version: '>=' + glib_min_version)
geocode_glib_dep = dependency('geocode-glib-1.0', version: '>= 3.10.0')
gio_dep = dependency('gio-2.0', version: '>= 2.53.0')
gio_unix_dep = dependency('gio-unix-2.0')
-gnome_desktop_dep = dependency('gnome-desktop-3.0', version: '>= 3.34.2')
+gnome_desktop_dep = dependency('gnome-desktop-3.0', version: '>= 3.37.1')
gsettings_desktop_dep = dependency('gsettings-desktop-schemas', version: '>= 3.35.91')
gtk_dep = dependency('gtk+-3.0', version: '>= 3.15.3')
gtk_x11_dep = dependency('gtk+-x11-3.0')
@@ -227,7 +227,7 @@ config_h.set10('HAVE_NETWORK_MANAGER', enable_network_manager)
# colord
enable_colord = get_option('colord')
if enable_colord
- colord_dep = dependency('colord', version: '>= 1.3.5')
+ colord_dep = dependency('colord', version: '>= 1.4.5')
endif
gnome = import('gnome')