summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorOlivier Fourdan <ofourdan@redhat.com>2021-03-19 17:49:45 +0100
committerBenjamin Berg <benjamin@sipsolutions.net>2021-07-26 15:47:10 +0000
commite10a1cc5e76b9ef48e3de88b9562c39e444ea8c4 (patch)
tree18f993c3a8f454743dd80215f90615b33e85b9e9 /meson.build
parent36127697182e56a2d8f86dbc63dd8af2f3abd581 (diff)
downloadgnome-settings-daemon-e10a1cc5e76b9ef48e3de88b9562c39e444ea8c4.tar.gz
xsettings: Add support for XFixes ClientDisconnectMode
The Xserver itself is capable of terminating itself once all X11 clients are gone, yet in a typical full session, there are a number of X11 clients such as gsd-xsettings running continuously. Those always-running clients will prevent the Xserver from terminating, because the actual number of X11 clients will never drop to 0. Use XFixes ClientDisconnectMode to inform the X11 server that it can terminate even if gsd-xsettings is still running. That will allow Xwayland to terminate automatically once regular clients have quit. On plain Xorg servers, the lifetime of the session is usually tied to the session manager or window manager, and this change will have no effect.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ba2a90ca..239ce871 100644
--- a/meson.build
+++ b/meson.build
@@ -106,6 +106,7 @@ pango_dep = dependency('pango', version: '>= 1.20.0')
polkit_gobject_dep = dependency('polkit-gobject-1', version: '>= 0.114')
upower_glib_dep = dependency('upower-glib', version: '>= 0.99.8')
x11_dep = dependency('x11')
+xfixes_dep = dependency('xfixes', version: '>= 6.0')
enable_systemd = get_option('systemd')
if enable_systemd