summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBenjamin Berg <bberg@redhat.com>2019-12-11 22:29:37 +0100
committerBenjamin Berg <benjamin@sipsolutions.net>2020-07-31 08:53:12 +0000
commitbc2ff7167adceafae28b5ba431d54a8454f66d7e (patch)
treec408e682741b1840caf2cce1b42c85c55ced587c /meson.build
parenta97734eb1e3535bec619d25f3f1690c800083d8f (diff)
downloadgnome-settings-daemon-bc2ff7167adceafae28b5ba431d54a8454f66d7e.tar.gz
meson: Bump systemd requirement to version 243
If we require version 243 we can rely on special targets like smartcard.target working. Also, from 242 onwards the sytemduserunitdir path resolving using systemd.pc works fine. Closes: #444
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 3 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 7fa3efe8..2516950e 100644
--- a/meson.build
+++ b/meson.build
@@ -111,14 +111,11 @@ x11_dep = dependency('x11')
enable_systemd = get_option('systemd')
if enable_systemd
- systemd_dep = dependency('systemd', required: false)
+ systemd_dep = dependency('systemd', version: '>= 243', required: false)
assert(systemd_dep.found(), 'Systemd support explicitly required, but systemd not found')
- # XXX: Once https://github.com/systemd/systemd/issues/9595 is fixed and we can
- # depend on this version, replace with something like:
- # systemduserunitdir = systemd_dep.get_pkgconfig_variable('systemduserunitdir')
- # and uncomment systemd_dep below
- systemd_userunitdir = join_paths(gsd_prefix, 'lib', 'systemd', 'user')
+ systemd_userunitdir = systemd_dep.get_pkgconfig_variable('systemduserunitdir',
+ define_variable: ['prefix', gsd_prefix])
endif
m_dep = cc.find_library('m')