summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNishal Kulkarni <kulknishu@gmail.com>2021-05-14 18:10:06 +0530
committerBenjamin Berg <benjamin@sipsolutions.net>2021-05-14 12:48:50 +0000
commitb23408d1cffd2ab07cb22fcf797137c41ef6f3af (patch)
tree3fdf38f47d3f68fe5770d74323aa4ecf1ed4ca02 /meson.build
parente5f62bd38b0f580b90427c46445d28450b012742 (diff)
downloadgnome-settings-daemon-b23408d1cffd2ab07cb22fcf797137c41ef6f3af.tar.gz
housekeeping: use grefcount
reference counting is implemented manually instead of using grefcount provided by glib. Fix: using grefcount and its functions for `DeleteData` struct Updated `glib_min_version` to 2.58
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 88e4f87d..65a1a54b 100644
--- a/meson.build
+++ b/meson.build
@@ -11,7 +11,7 @@ gsd_major_version = version_array[0].to_int()
gsd_api_name = '@0@-@1@'.format(meson.project_name(), gsd_major_version)
-glib_min_version = '2.56'
+glib_min_version = '2.58'
glib_version_def = 'GLIB_VERSION_@0@_@1@'.format(
glib_min_version.split('.')[0], glib_min_version.split('.')[1])