summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2022-08-23 20:52:04 -0400
committerMatt Turner <mattst88@gmail.com>2022-08-23 20:52:04 -0400
commit5219217586dcbaaeadbe38db7ccb36a67fe1986a (patch)
treedf52053d56d7c759f2a4f1c19fdc28f7ec67d6e1 /meson.build
parent1c61fa79e525df2286273a3e9aa277764a15c242 (diff)
downloadgnome-settings-daemon-5219217586dcbaaeadbe38db7ccb36a67fe1986a.tar.gz
build: Use GNOME module post_install()
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 0335d25a..aec2ec2c 100644
--- a/meson.build
+++ b/meson.build
@@ -2,7 +2,7 @@ project(
'gnome-settings-daemon', 'c',
version: '43.beta',
license: [ 'GPL2+', 'LGPLv2+' ],
- meson_version: '>= 0.49.0'
+ meson_version: '>= 0.57.0'
)
gsd_version = meson.project_version()
@@ -256,9 +256,8 @@ configure_file(
configuration: config_h
)
-meson.add_install_script(
- 'meson_post_install.py',
- gsd_datadir
+gnome.post_install(
+ glib_compile_schemas: true,
)
output = '\n ' + meson.project_name() + ' ' + meson.project_version() +'\n'