summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSamuel Thibault <samuel.thibault@ens-lyon.org>2020-08-07 15:19:52 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2020-08-18 12:38:05 +0200
commit4cd4c3f9f6c8e033e61d647bfb0bd4098a452708 (patch)
tree20b6f14cb3396f1f7f9c200bee674a7775de55bb /meson.build
parent10d241b3d9b555684933a550ed0a06d034f924d0 (diff)
downloadgnome-settings-daemon-4cd4c3f9f6c8e033e61d647bfb0bd4098a452708.tar.gz
colord: make it optional
colord has become completely dependent on udev, not available on non-Linux, so make the color plugin optional to fix build there.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b794652c..0b314c57 100644
--- a/meson.build
+++ b/meson.build
@@ -90,7 +90,6 @@ endif
add_project_arguments(common_flags + compiler_flags, language: 'c')
glib_dep = dependency('glib-2.0', version: '>=' + glib_min_version)
-colord_dep = dependency('colord', version: '>= 1.3.5')
geocode_glib_dep = dependency('geocode-glib-1.0', version: '>= 3.10.0')
gio_dep = dependency('gio-2.0', version: '>= 2.53.0')
gio_unix_dep = dependency('gio-unix-2.0')
@@ -225,6 +224,12 @@ if enable_network_manager
endif
config_h.set10('HAVE_NETWORK_MANAGER', enable_network_manager)
+# colord
+enable_colord = get_option('colord')
+if enable_colord
+ colord_dep = dependency('colord', version: '>= 1.3.5')
+endif
+
gnome = import('gnome')
i18n = import('i18n')
pkg = import('pkgconfig')