summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKalev Lember <klember@redhat.com>2021-02-15 16:15:58 +0100
committerKalev Lember <klember@redhat.com>2021-02-15 17:05:45 +0100
commit49ca22626e0553b3a521e1601bc84c5429a438cd (patch)
tree3cbe88f23182daf38e7015e62190f788a4eb363b /meson.build
parent5743b91b985d7bfeb3d6b656242bd1f7f58d19ac (diff)
downloadgnome-settings-daemon-49ca22626e0553b3a521e1601bc84c5429a438cd.tar.gz
xsettings: Go back to loading gtk modules from lib/gnome-settings-daemon-3.0
This is where other projects install the gtk modules desktop files. There is little point in rebuilding all of the other projects every time gnome-settings-daemon version changes, so just leave the directory name hardcoded to what it was during GNOME 3.x. Also, while at this, print out the configured gtk modules directory from meson to make it clear where it is.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 24bb9a95..c8ab875e 100644
--- a/meson.build
+++ b/meson.build
@@ -35,6 +35,9 @@ gsd_schemadir = join_paths(gsd_datadir, 'glib-2.0', 'schemas')
gsd_xdg_autostart = join_paths(gsd_sysconfdir, 'xdg', 'autostart')
+gsd_3_0_api_name = '@0@-@1@'.format(meson.project_name(), '3.0')
+gsd_gtk_modules_directory = join_paths(gsd_libdir, gsd_3_0_api_name, 'gtk-modules')
+
gsd_buildtype = get_option('buildtype')
host_is_darwin = host_machine.system().contains('darwin')
@@ -262,6 +265,7 @@ output += ' libexecdir: ' + gsd_libexecdir + '\n'
output += ' bindir: ' + gsd_bindir + '\n'
output += ' sysconfdir: ' + gsd_sysconfdir + '\n'
output += ' datadir: ' + gsd_datadir + '\n\n'
+output += ' gtk modules dir: ' + gsd_gtk_modules_directory + '\n\n'
output += ' source code location: ' + meson.source_root() + '\n'
output += ' compiler: ' + cc.get_id() + '\n'
output += ' cflags: ' + ' '.join(compiler_flags) + '\n\n'