summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2021-07-16 16:02:36 +0200
committerBastien Nocera <hadess@hadess.net>2021-07-16 17:10:54 +0200
commit28e28e9e598342c897ae5ca350d0da6f4aea057b (patch)
tree359a42f56b69a45a41fd6c18999967ee6c6941ec /meson.build
parentb6c23eb2b378942e746676cb69f210ec0cb1eeb6 (diff)
downloadgnome-settings-daemon-28e28e9e598342c897ae5ca350d0da6f4aea057b.tar.gz
build: Fix str/bool comparison
gnome-settings-daemon/meson.build:87: WARNING: Trying to compare values of different types (str, bool) using ==. The result of this is undefined and will become a hard error in a future Meson release.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index fdf71713..ba2a90ca 100644
--- a/meson.build
+++ b/meson.build
@@ -82,9 +82,7 @@ elif gsd_buildtype.contains('release')
common_flags += ['-DG_DISABLE_CAST_CHECKS']
endif
-# Workaround for meson's bug
-# https://github.com/mesonbuild/meson/pull/1896
-if get_option('b_ndebug') == true
+if get_option('b_ndebug') == 'true'
common_flags += ['-DG_DISABLE_ASSERT']
endif