summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-10-15 16:10:51 +0200
committerStef Walter <stefw@gnome.org>2013-10-15 16:16:22 +0200
commitd231d9c50dd0be1beb8d1d9293005d49cc90e7f8 (patch)
tree9a534df5d8fbad4620799e6926b8a4017b176540 /docs/Makefile.am
parent2ec2e06691b0e99815b9a13a8682eda90d3ffaf9 (diff)
downloadgnome-keyring-d231d9c50dd0be1beb8d1d9293005d49cc90e7f8.tar.gz
daemon: Add gnome-keyring-daemon manual page
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am27
1 files changed, 26 insertions, 1 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index 3f519b7f..de1d4c14 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -1,5 +1,30 @@
+man1_MANS = \
+ gnome-keyring-daemon.1
+ $(NULL)
+
+MAN_IN_FILES = \
+ $(man1_MANS:.1=.xml)
+
+CLEANFILES = \
+ $(man1_MANS)
+
+XSLTPROC_FLAGS = \
+ --nonet \
+ --stringparam man.output.quietly 1 \
+ --stringparam funcsynopsis.style ansi \
+ --stringparam man.th.extra1.suppress 1 \
+ --stringparam man.authors.section.enabled 0 \
+ --stringparam man.copyright.section.enabled 0
+
+XSLTPROC_MAN = \
+ $(XSLTPROC) $(XSLTPROC_FLAGS) http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
+
+.xml.1:
+ $(AM_V_GEN) $(XSLTPROC_MAN) $<
+
EXTRA_DIST = \
file-format.txt \
keyring-intro.txt \
- gnome-keyring.svg \ No newline at end of file
+ gnome-keyring.svg \
+ $(MAN_IN_FILES)