summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2012-01-14 21:45:18 -0500
committerColin Walters <walters@verbum.org>2012-01-14 21:45:18 -0500
commit8b4cb9d332b84db970bf446ad9576ad98ba448e5 (patch)
treea1d41b9a6c0a0d5a65ce0285453c5d6c645d637e /configure.in
parent0df0775700957967848e59440af24da9d6654a01 (diff)
downloadgnome-doc-utils-8b4cb9d332b84db970bf446ad9576ad98ba448e5.tar.gz
build: Add --disable-documentation option
This may sound weird for gnome-doc-utils, but basically I need a way to bootstrap an operating system without documentation initially, because it's the source of big dependency cycles. This configure option is enough to get the m4 macros installed, and then move from there to building GDM without documentation too.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 15d97a4..dd56f21 100644
--- a/configure.in
+++ b/configure.in
@@ -21,6 +21,11 @@ AC_PROG_LN_S
gdu_cv_have_gdu=yes
GNOME_DOC_DEFINES
+AC_ARG_ENABLE([documentation],
+ AS_HELP_STRING([--enable-documentation], [enable documentation generated via XSLT]),
+ [], [enable_documentation=yes])
+AM_CONDITIONAL(ENABLE_DOCUMENTATION, test x$enable_documentation = xyes)
+
AC_ARG_ENABLE([build-utils],
AC_HELP_STRING([--enable-build-utils],
[build and install the build utilities [default=yes]]),,