summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@src.gnome.org>1999-02-04 13:27:05 +0000
committerMartin Baulig <martin@src.gnome.org>1999-02-04 13:27:05 +0000
commitfede401de24c24de782befee9cb4c88d689e40a5 (patch)
tree91810537b5bdfab4dcafd049a2e58a8030337d70 /Makefile.am
parent27e19ca975b25e66e49e00bfd80995f2bd017452 (diff)
downloadgnome-common-fede401de24c24de782befee9cb4c88d689e40a5.tar.gz
To make this work both for GNOME Applications inside and outside the
GNOME CVS Tree I did the following: * There is an `INSIDE_GNOME_COMMON' automake conditional which is defined in two places: - macros/aclocal-includes.m4 defines this to always be false. - gnome-common/configure.in does not include anything from macros and defines this to be true. * We use this automake conditional in the macros/Makefile.am to install $(MACROS), autogen.sh, gnome-common.m4 and a newly created gnome-macros.dep in `$(datadir)/aclocal/gnome'. Since aclocal doesn't look in subdirectories we can safely install them there even when compiling from CVS. Also, there is no need to make any change to any existing application in the GNOME CVS Tree - really fine ... * When we're outside the GNOME CVS Tree we simply need to tell aclocal that it should also look in `$(datadir)/aclocal/gnome' and it will find all the macros. The is a `gnome-skel' module in CVS that can be used as a starting point when writing a new GNOME Application that should be used outside CVS. February 4, 1999, Martin Baulig <martin@home-of-linux.org> svn path=/trunk/; revision=609
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 484f4cf..e38ab08 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,9 @@
-## if <internationalization support>
-#SUBDIRS = po intl macros support # <your subdirs here>
-## else
-SUBDIRS = macros support # <your subdirs here>
-## endif
+SUBDIRS = macros
-## to automatically rebuild aclocal.m4 if any of the macros in
-## `macros/' change
-@MAINT@include macros/macros.dep
-@MAINT@macros/macros.dep: macros/Makefile.am
-@MAINT@ cd macros && $(MAKE) macros.dep
+EXTRA_DIST = gnome-common.spec
+
+dist-hook:
+ for subdir in intl support ; do \
+ mkdir $(distdir)/$$subdir ; \
+ cp -pr $(srcdir)/$$subdir $(distdir) ; \
+ done