summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>2000-11-21 17:18:11 +0000
committerMartin Baulig <martin@src.gnome.org>2000-11-21 17:18:11 +0000
commit1f8d693b87ce9132f3880809f52ede46727ef5e4 (patch)
treeb9efbc3c57f4d5c98e7beffaa45381ba6ddd64eb /Makefile.am
parentc0a8b9ac7e2ffa3ec0199412354df7441226bbfc (diff)
downloadgnome-common-1f8d693b87ce9132f3880809f52ede46727ef5e4.tar.gz
Set version number to 1.2.1.
2000-11-21 Martin Baulig <martin@home-of-linux.org> * configure.in: Set version number to 1.2.1. * configure.in (--enable-platform-gnome-2): New configure command line argument to enable support for the GNOME 2.x platform. (PLATFORM_GNOME_2): New automake conditional. * Do the GNOME_SUPPORT_CHECKS here if we're on the GNOME 2.x platform. * Makefile.am (SUBDIRS): Conditionally add support for the GNOME 2.x platform. * acinclude.m4: New file. Put stuff from gnome-support.m4 and need-declaration.m4 here. svn path=/trunk/; revision=1466
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 13 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 7484fd7..062e33e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,15 @@
-SUBDIRS = bin macros macros2 doc
+if PLATFORM_GNOME_2
+pkgconfig_file = gnome-common-2.0.pc
+support = support
+else
+pkgconfig_file =
+support =
+endif
-EXTRA_DIST = gnome-common.spec
+SUBDIRS = bin macros macros2 doc $(support)
+
+EXTRA_DIST = gnome-common.spec gnome-common-2.0.pc.in gnome-common.pc.in
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = $(pkgconfig_file) gnome-common.pc
-dist-hook:
- for subdir in intl support ; do \
- mkdir $(distdir)/$$subdir ; \
- cp -pr $(srcdir)/$$subdir $(distdir) ; \
- done