summaryrefslogtreecommitdiff
path: root/mpn/Makefile.am
diff options
context:
space:
mode:
authorTorbjorn Granlund <tege@gmplib.org>2008-09-08 20:40:35 +0200
committerTorbjorn Granlund <tege@gmplib.org>2008-09-08 20:40:35 +0200
commitc104387fe6eb47607d9148c5f41a1f638290a84b (patch)
tree6642faae3843ce08697b6e4acc20a6c12d2da3e7 /mpn/Makefile.am
parent0cfec534ae489a35e8442e472d0111fc3b255a8e (diff)
downloadgmp-c104387fe6eb47607d9148c5f41a1f638290a84b.tar.gz
Add support, testing, and timing of mpn_mul_3 and mpn_mul_4.
* gmp-impl.h (mpn_mul_3, mpn_mul_4): Declare. * tests/tests.h (refmpn_mul_3, refmpn_mul_4): Declare. * tests/try.c (param_init): Set things up for mpn_mul_3 and mpn_mul_4. (choice_array): Likewise. (call): Likewise. * mpn/Makefile.am (nodist_EXTRA_libmpn_la_SOURCES): Add mul_3.c and mul_4. * mpn/asm-defs.m4: Define mul_3 and mul_4. * tests/refmpn.c (refmpn_mul_N): New function. (refmpn_mul_2): Remove old definition, call refmpn_mul_N. (refmpn_mul_3, refmpn_mul_4): New functions. * tune/common.c (speed_mpn_mul_3, speed_mpn_mul_4): New functions. * tune/speed.h (speed_mpn_mul_3, speed_mpn_mul_4): Declare. * tune/speed.c (routine): New entries for mpn_mul_2 and mpn_mul_3.
Diffstat (limited to 'mpn/Makefile.am')
-rw-r--r--mpn/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/mpn/Makefile.am b/mpn/Makefile.am
index 6ad305c6c..78f88e24c 100644
--- a/mpn/Makefile.am
+++ b/mpn/Makefile.am
@@ -41,7 +41,7 @@ nodist_EXTRA_libmpn_la_SOURCES = \
gcd_finda.c gcd_1.c gcdext.c get_d.c get_str.c \
hamdist.c hgcd2.c hgcd.c invert_limb.c \
ior_n.c iorn_n.c jacbase.c lshift.c mod_1.c mod_34lsub1.c mode1o.c \
- mul.c mul_1.c mul_2.c mul_fft.c mul_n.c mul_basecase.c \
+ mul.c mul_1.c mul_2.c mul_3.c mul_4.c mul_fft.c mul_n.c mul_basecase.c \
mul_toom22.c mul_toom32.c mul_toom42.c \
mullow_n.c mullow_basecase.c nand_n.c nior_n.c perfsqr.c popcount.c \
pre_divrem_1.c pre_mod_1.c pow_1.c qstack.c random.c random2.c rshift.c \