summaryrefslogtreecommitdiff
path: root/mpn/Makefile.am
diff options
context:
space:
mode:
authorKevin Ryde <user42@zip.com.au>2002-11-28 01:46:43 +0100
committerKevin Ryde <user42@zip.com.au>2002-11-28 01:46:43 +0100
commit82b9254187960c47327f9a7aacefba2f98c54e6a (patch)
treebf49b0312c7f2cdf24cc7ee607fb28d34d627464 /mpn/Makefile.am
parentab67f725375ae29077f1d47bdea564253c91a1e4 (diff)
downloadgmp-82b9254187960c47327f9a7aacefba2f98c54e6a.tar.gz
* mpn/Makefile.am (nodist_EXTRA_libmpn_la_SOURCES): Use this rather
than libdummy.
Diffstat (limited to 'mpn/Makefile.am')
-rw-r--r--mpn/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/mpn/Makefile.am b/mpn/Makefile.am
index 9d7554b81..1ce8b5893 100644
--- a/mpn/Makefile.am
+++ b/mpn/Makefile.am
@@ -29,13 +29,12 @@ INCLUDES = -D__GMP_WITHIN_GMP -I$(top_srcdir) \
OFILES = @mpn_objects@
-# All possible mpn normal and optional function files are listed here as C
-# sources for a dummy library, to get automake to generate ansi2knr rules
-# for each. Such rules will be ignored for any that are instead implemented
-# with a .asm (or whatever) for a particular target.
+# All possible mpn normal and optional function files are listed here, to
+# get automake to generate ansi2knr rules for each. Such rules will be
+# ignored for any that are instead implemented with a .asm (or whatever) for
+# a particular target.
#
-EXTRA_LTLIBRARIES = libdummy.la
-nodist_libdummy_la_SOURCES = \
+nodist_EXTRA_libmpn_la_SOURCES = \
add.c add_1.c add_n.c \
addmul_1.c addmul_2.c addmul_3.c addmul_4.c addmul_5.c addmul_6.c \
addmul_7.c addmul_8.c \
@@ -53,7 +52,6 @@ nodist_libdummy_la_SOURCES = \
sqrtrem.c sub.c sub_1.c sub_n.c submul_1.c \
tdiv_qr.c udiv_qrnnd.c udiv_w_sdiv.c xor_n.c xnor_n.c
-
noinst_LTLIBRARIES = libmpn.la
nodist_libmpn_la_SOURCES = fib_table.c mp_bases.c
libmpn_la_LIBADD = $(OFILES)