summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authortege <tege@gmplib.org>2003-11-05 05:15:52 +0100
committertege <tege@gmplib.org>2003-11-05 05:15:52 +0100
commit5ff14db13d03f25c2fcd08569b3eec3ccfedf2a6 (patch)
tree3d700ae9ac452480f6fb6b10c142abdd277d8042 /configure.in
parent1fb30c217a4a1f2f02ec99938181938c76ae632d (diff)
downloadgmp-5ff14db13d03f25c2fcd08569b3eec3ccfedf2a6.tar.gz
(POWERPC64_PATTERN): Handle *-*-linux*.
Use linux64.m4.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 76a4afa49..1f66e2650 100644
--- a/configure.in
+++ b/configure.in
@@ -943,6 +943,23 @@ case $host in
path_mode32="powerpc64/mode32 powerpc64"
limb_mode32=longlong
;;
+ *-*-linux*)
+ # On Linux, assume the processor is in 64-bit mode. Unfortunately,
+ # some Linux environments have a gcc that is always in 64-bit mode,
+ # while other Linux environments require -m64. To make matters
+ # worse. To avoid tripping a gcc bug (that we have a feature test
+ # for) we don't pass -mpowerpc64, but that is implied by -m64, and
+ # is hopefully the default where -m64 is rejected.
+ #
+ # FIXME: We should try gcc64 here too, probably after "gcc -m64"
+ #
+ abilist="mode64 $abilist"
+ cclist_mode64="gcc"
+ gcc_mode64_cflags="-O3"
+ gcc_mode64_cflags_optlist="cpu m64"
+ path_mode64="powerpc64/mode64 powerpc64"
+ gcc_cflags_m64="-m64"
+ ;;
esac
;;
esac
@@ -2787,6 +2804,11 @@ if test "$gmp_asm_syntax_testing" != no; then
*) GMP_INCLUDE_MPN(powerpc32/aix.m4) ;;
esac
;;
+ powerpc*-*-linux*)
+ case $ABI in
+ mode64) GMP_INCLUDE_MPN(powerpc64/linux64.m4) ;;
+ esac
+ ;;
esac
;;
power*-*-aix*)