summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTorbjorn Granlund <tg@gmplib.org>2017-01-24 21:08:21 +0100
committerTorbjorn Granlund <tg@gmplib.org>2017-01-24 21:08:21 +0100
commitf0675480df1d15e279ab1cff1b14f334e338aca5 (patch)
tree68d09658950738514c33232a68962955b7e6c211 /configure.ac
parent5f363223e5936651c178894b0e222fa1b9265d0e (diff)
downloadgmp-f0675480df1d15e279ab1cff1b14f334e338aca5.tar.gz
Invoke AC_PROG_CC_C99 instead of AC_PROG_CC_STDC.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d7351dec2..f86f451f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ dnl Process this file with autoconf to produce a configure script.
define(GMP_COPYRIGHT,[[
-Copyright 1996-2016 Free Software Foundation, Inc.
+Copyright 1996-2017 Free Software Foundation, Inc.
This file is part of the GNU MP Library.
@@ -2390,9 +2390,12 @@ AC_SUBST(DEFN_LONG_LONG_LIMB)
# The C compiler and preprocessor, put into ANSI mode if possible.
AC_PROG_CC
-AC_PROG_CC_STDC
+AC_PROG_CC_C99
AC_PROG_CPP
+if test "$ac_cv_prog_cc_c99" = no; then
+ AC_MSG_ERROR([Cannot find a C99 capable compiler])
+fi
# The C compiler on the build system, and associated tests.
GMP_PROG_CC_FOR_BUILD