summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJonathon Jongsma <jjongsma@src.gnome.org>2008-03-04 16:36:24 +0000
committerJonathon Jongsma <jjongsma@src.gnome.org>2008-03-04 16:36:24 +0000
commit6077711742ac64802b9ce220e15b5fecc77e4f20 (patch)
treefd13b030ebf072728833dabab802bff2e2f8a7dc /Makefile.am
parent4b3ceab7f29807e7deb161de8feaedefbc577ee6 (diff)
downloadglibmm-6077711742ac64802b9ce220e15b5fecc77e4f20.tar.gz
updated the 'release' target to give a bit more helpful error messages
* Makefile.am: updated the 'release' target to give a bit more helpful error messages svn path=/trunk/; revision=635
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a6fbe114..cc5fbee8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,7 +66,10 @@ ROOT_KEY=Repository Root:
SVN_ROOT=`svn info |grep "$(ROOT_KEY)" |sed -e "s/$(ROOT_KEY)\s*//"`
tag-release: distcheck
- svn cp -m "tag $(PACKAGE) $(VERSION)" $(SVN_PATH)@$(SVN_REV) $(SVN_ROOT)/tags/$(PACKAGE)-$(VERSION)
+ @svn cp -r$(SVN_REV) -m "tag $(PACKAGE) $(VERSION)" $(SVN_PATH) $(SVN_ROOT)/tags/$(PACKAGE)-$(VERSION) \
+ || (echo "Tagging failed. Do you have local changes that are not committed?" \
+ && echo "Try running `svn update`." && false)
+ @echo "Release Tagged."
release: tag-release
scp $(DIST_ARCHIVES) master.gnome.org: