summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-09 20:02:48 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-09 20:13:40 -0400
commit402fa33cf0815f04b2d621ce57418d71b432740a (patch)
tree836211e971dcf2560b6e5121b7a4401400b3eadf
parent2f012b713af72215364cd233853335297729fb4e (diff)
downloadglibc-gentoo/2.22.tar.gz
configure: fix `test ==` usagegentoo/2.22
POSIX defines the = operator, but not ==. Fix the few places where we incorrectly used ==. (cherry picked from commit b2d4456b333970ab4cb01ed8045b9a8d2c4832f3) (cherry picked from commit e2c17de539da301c96afa4181347c63eb94d99b1)
-rw-r--r--sysdeps/i386/configure2
-rw-r--r--sysdeps/i386/configure.ac2
-rw-r--r--sysdeps/x86_64/configure4
-rw-r--r--sysdeps/x86_64/configure.ac4
4 files changed, 6 insertions, 6 deletions
diff --git a/sysdeps/i386/configure b/sysdeps/i386/configure
index ab66c08160..b0ef1fc26c 100644
--- a/sysdeps/i386/configure
+++ b/sysdeps/i386/configure
@@ -262,7 +262,7 @@ rm -f conftest*
fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $libc_cv_asm_mpx" >&5
$as_echo "$libc_cv_asm_mpx" >&6; }
-if test $libc_cv_asm_mpx == yes; then
+if test $libc_cv_asm_mpx = yes; then
$as_echo "#define HAVE_MPX_SUPPORT 1" >>confdefs.h
fi
diff --git a/sysdeps/i386/configure.ac b/sysdeps/i386/configure.ac
index a3f3067fb7..5647cb044d 100644
--- a/sysdeps/i386/configure.ac
+++ b/sysdeps/i386/configure.ac
@@ -99,7 +99,7 @@ else
libc_cv_asm_mpx=no
fi
rm -f conftest*])
-if test $libc_cv_asm_mpx == yes; then
+if test $libc_cv_asm_mpx = yes; then
AC_DEFINE(HAVE_MPX_SUPPORT)
fi
diff --git a/sysdeps/x86_64/configure b/sysdeps/x86_64/configure
index 552f535ac6..e6a9651181 100644
--- a/sysdeps/x86_64/configure
+++ b/sysdeps/x86_64/configure
@@ -118,7 +118,7 @@ rm -f conftest*
fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $libc_cv_asm_avx512" >&5
$as_echo "$libc_cv_asm_avx512" >&6; }
-if test $libc_cv_asm_avx512 == yes; then
+if test $libc_cv_asm_avx512 = yes; then
$as_echo "#define HAVE_AVX512_ASM_SUPPORT 1" >>confdefs.h
fi
@@ -245,7 +245,7 @@ rm -f conftest*
fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $libc_cv_asm_mpx" >&5
$as_echo "$libc_cv_asm_mpx" >&6; }
-if test $libc_cv_asm_mpx == yes; then
+if test $libc_cv_asm_mpx = yes; then
$as_echo "#define HAVE_MPX_SUPPORT 1" >>confdefs.h
fi
diff --git a/sysdeps/x86_64/configure.ac b/sysdeps/x86_64/configure.ac
index e7208c9b30..b721173450 100644
--- a/sysdeps/x86_64/configure.ac
+++ b/sysdeps/x86_64/configure.ac
@@ -35,7 +35,7 @@ else
libc_cv_asm_avx512=no
fi
rm -f conftest*])
-if test $libc_cv_asm_avx512 == yes; then
+if test $libc_cv_asm_avx512 = yes; then
AC_DEFINE(HAVE_AVX512_ASM_SUPPORT)
fi
@@ -87,7 +87,7 @@ else
libc_cv_asm_mpx=no
fi
rm -f conftest*])
-if test $libc_cv_asm_mpx == yes; then
+if test $libc_cv_asm_mpx = yes; then
AC_DEFINE(HAVE_MPX_SUPPORT)
fi