summaryrefslogtreecommitdiff
path: root/tests/gobject/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/gobject/meson.build')
-rw-r--r--tests/gobject/meson.build38
1 files changed, 0 insertions, 38 deletions
diff --git a/tests/gobject/meson.build b/tests/gobject/meson.build
deleted file mode 100644
index eaf4f6cde..000000000
--- a/tests/gobject/meson.build
+++ /dev/null
@@ -1,38 +0,0 @@
-gobject_tests = {
-}
-
-common_c_args = test_cargs + ['-DGLIB_DISABLE_DEPRECATION_WARNINGS']
-common_deps = [libm, thread_dep, libglib_dep, libgobject_dep]
-
-foreach test_name, extra_args : gobject_tests
- source = extra_args.get('source', test_name + '.c')
- extra_sources = extra_args.get('extra_sources', [])
- install = installed_tests_enabled and extra_args.get('install', true)
- template = extra_args.get('tap', false) ? installed_tests_template_tap : installed_tests_template
-
- if install
- test_conf = configuration_data()
- test_conf.set('installed_tests_dir', installed_tests_execdir)
- test_conf.set('program', test_name)
- test_conf.set('env', '')
- configure_file(
- input: template,
- output: test_name + '.test',
- install_dir: installed_tests_metadir,
- configuration: test_conf
- )
- endif
-
- # FIXME? $(GLIB_DEBUG_FLAGS)
- exe = executable(test_name, [source, extra_sources],
- c_args : common_c_args + extra_args.get('c_args', []),
- dependencies : common_deps + extra_args.get('dependencies', []),
- install_dir: installed_tests_execdir,
- install: install,
- )
-
- suite = ['gobject'] + extra_args.get('suite', [])
- timeout = suite.contains('slow') ? test_timeout_slow : test_timeout
- # FIXME? TESTS_ENVIRONMENT = LIBCHARSET_ALIAS_DIR=$(top_builddir)/glib/libcharset
- test(test_name, exe, env : test_env, timeout : timeout, suite : suite)
-endforeach