summaryrefslogtreecommitdiff
path: root/tests/gobject/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/gobject/meson.build')
-rw-r--r--tests/gobject/meson.build42
1 files changed, 0 insertions, 42 deletions
diff --git a/tests/gobject/meson.build b/tests/gobject/meson.build
index a02480e02..8766932f5 100644
--- a/tests/gobject/meson.build
+++ b/tests/gobject/meson.build
@@ -1,47 +1,5 @@
-# We cannot use gnome.genmarshal() here
-testmarshal_h = custom_target('testmarshal_h',
- output : 'testmarshal.h',
- input : 'testmarshal.list',
- command : [
- python, glib_genmarshal,
- '--prefix=test_marshal',
- '--output=@OUTPUT@',
- '--quiet',
- '--header',
- '@INPUT@',
- ],
-)
-
-testmarshal_c = custom_target('testmarshal_c',
- output : 'testmarshal.c',
- input : 'testmarshal.list',
- command : [
- python, glib_genmarshal,
- '--prefix=test_marshal',
- '--include-header=testmarshal.h',
- '--output=@OUTPUT@',
- '--quiet',
- '--body',
- '@INPUT@',
- ],
-)
-
gobject_tests = {
- 'deftype' : {},
- 'defaultiface' : {
- 'extra_sources' : ['testmodule.c'],
- },
- 'dynamictype' : {
- 'extra_sources' : ['testmodule.c'],
- },
- 'override' : {},
- 'signals' : {},
- 'singleton' : {},
- 'references' : {},
'testgobject' : {},
- 'accumulator' : {
- 'extra_sources' : [testmarshal_c, testmarshal_h],
- },
}
if host_system != 'windows'