summaryrefslogtreecommitdiff
path: root/gobject/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gobject/tests/meson.build')
-rw-r--r--gobject/tests/meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/gobject/tests/meson.build b/gobject/tests/meson.build
index a880dfb33..96a7b40d3 100644
--- a/gobject/tests/meson.build
+++ b/gobject/tests/meson.build
@@ -186,7 +186,13 @@ foreach test_name, extra_args : gobject_tests
timeout = timeout * 10
endif
- test(test_name, exe, env : test_env, timeout : timeout, suite : suite)
+ test(test_name,
+ exe,
+ protocol : extra_args.get('protocol', test_protocol),
+ env : test_env,
+ timeout : timeout,
+ suite : suite,
+ )
endforeach
foreach test_name, extra_args : python_tests
@@ -200,6 +206,7 @@ foreach test_name, extra_args : python_tests
test(
test_name,
python,
+ protocol : extra_args.get('protocol', test_protocol),
depends: depends,
args: ['-B', files(test_name)],
env: test_env,