summaryrefslogtreecommitdiff
path: root/gmodule/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gmodule/meson.build')
-rw-r--r--gmodule/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/gmodule/meson.build b/gmodule/meson.build
index 7713a975d..5119e0be0 100644
--- a/gmodule/meson.build
+++ b/gmodule/meson.build
@@ -28,11 +28,11 @@ if g_module_impl == 'G_MODULE_IMPL_DL'
message('Building for MSVC: assuming that symbols are prefixed with underscore')
g_module_need_uscore = 1
elif meson.can_run_host_binaries()
- # FIXME: communicate result via stdout instead of return value, so non-0 return is not printed in bold red
rres = cc.run(dlopen_dlsym_test_code,
dependencies : libdl_dep,
name : 'dlsym() preceding underscores')
- if host_system == 'windows' or (rres.compiled() and rres.returncode() == 0)
+ if host_system == 'windows' or (rres.compiled() and
+ rres.returncode() == 0 and rres.stdout().to_int() == 0)
g_module_need_uscore = 1
endif
else