summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 0 insertions, 42 deletions
diff --git a/configure.ac b/configure.ac
index 6df0dfa82..fd6c0d953 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1317,48 +1317,6 @@ if test x$glib_cv_langinfo_abaltmon = xyes; then
fi
AC_LANG_RESTORE
-dnl ****************************************
-dnl *** posix_memalign ***
-dnl ****************************************
-AC_MSG_CHECKING(for a compliant posix_memalign() implementation)
-AC_CACHE_VAL(glib_cv_compliant_posix_memalign,[
- glib_cv_compliant_posix_memalign=0
- if test "$ac_cv_func_posix_memalign" = "yes" ; then
- AC_TRY_RUN([
- #define _XOPEN_SOURCE 600
- #include <stdlib.h> /* posix_memalign() should be defined here */
- /* some systems break if #include <malloc.h> used */
- static void test_memalign (size_t boundary, size_t size) {
- void *mem = 0;
- if (posix_memalign (&mem, boundary, size) != 0 || !mem)
- exit (1);
- else
- free (mem);
- }
- int main() {
- test_memalign ( 128, 128 - 2 * sizeof (void*));
- test_memalign ( 256, 256 - 2 * sizeof (void*));
- test_memalign ( 512, 512 - 2 * sizeof (void*));
- test_memalign ( 1024, 1024 - 2 * sizeof (void*));
- test_memalign ( 2048, 2048 - 2 * sizeof (void*));
- test_memalign ( 4096, 4096 - 2 * sizeof (void*));
- test_memalign ( 8192, 8192 - 2 * sizeof (void*));
- test_memalign (16384, 16384 - 2 * sizeof (void*));
- test_memalign (32768, 32768 - 2 * sizeof (void*));
- exit (0); /* success */
- }
- ],
- [glib_cv_compliant_posix_memalign=1], [], [:])
- :
- fi
- ])
-AS_IF([test "$glib_cv_compliant_posix_memalign" = "1"], [
- AC_MSG_RESULT(yes)
- AC_DEFINE(POSIX_MEMALIGN_WITH_COMPLIANT_ALLOCS, 1, [define if posix_memalign() can allocate any size])
-], [
- AC_MSG_RESULT(no)
-])
-
dnl ****************************************
dnl *** strlcpy/strlcat ***