summaryrefslogtreecommitdiff
path: root/tools/meson.build
diff options
context:
space:
mode:
authorPhilip Withnall <pwithnall@endlessos.org>2022-05-11 13:11:01 +0100
committerPhilip Withnall <pwithnall@endlessos.org>2022-05-11 13:11:01 +0100
commit512975088403f47585cd93bdc79c9dc5a868b7f6 (patch)
tree14d5291f1fa3f7a80dd3ce576c05cb38fe0a8aa0 /tools/meson.build
parent0dc53687f42ea3c0d520119e47898338d7bfc922 (diff)
downloadglib-512975088403f47585cd93bdc79c9dc5a868b7f6.tar.gz
tools: Move glib.supp to tools directory
This tidies up the root directory a bit more. Signed-off-by: Philip Withnall <pwithnall@endlessos.org>
Diffstat (limited to 'tools/meson.build')
-rw-r--r--tools/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/meson.build b/tools/meson.build
index f77ccc860..d550a0e37 100644
--- a/tools/meson.build
+++ b/tools/meson.build
@@ -12,3 +12,10 @@ if have_sh
output : 'glib-gettextize',
configuration : gettextize_conf)
endif
+
+if host_system != 'windows'
+ # Install Valgrind suppression file (except on Windows,
+ # as Valgrind is currently not supported on Windows)
+ install_data('glib.supp',
+ install_dir : join_paths(get_option('datadir'), 'glib-2.0', 'valgrind'))
+endif