summaryrefslogtreecommitdiff
path: root/gthread/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2008-03-16 10:16:57 +0000
committerTor Lillqvist <tml@src.gnome.org>2008-03-16 10:16:57 +0000
commite2ee29dd2c8ccda29e8a3f8b88fb7cc249b08a48 (patch)
tree37d159c4ae7773603ae5d231d101bb3b2403e1d9 /gthread/Makefile.am
parentff69c53da9c242d080427968afd0864739c3bfa9 (diff)
downloadglib-e2ee29dd2c8ccda29e8a3f8b88fb7cc249b08a48.tar.gz
Don't bother defining Autoconf variables for glib.def, gmodule.def,
2008-03-16 Tor Lillqvist <tml@novell.com> * configure.in: Don't bother defining Autoconf variables for glib.def, gmodule.def, gobject.def and gthread.def when this can be handled easily in */Makefile.am which are the only files that use them. Remove also TESTGMODULE_EXP which isn't used at all. * */Makefile.am: Corrsponding changes. svn path=/trunk/; revision=6722
Diffstat (limited to 'gthread/Makefile.am')
-rw-r--r--gthread/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gthread/Makefile.am b/gthread/Makefile.am
index 6d91d4d60..07dc0a20d 100644
--- a/gthread/Makefile.am
+++ b/gthread/Makefile.am
@@ -47,6 +47,7 @@ endif
if OS_WIN32
export_symbols = -export-symbols $(srcdir)/gthread.def
+gthread_def = gthread.def
install-def-file:
$(INSTALL) $(srcdir)/gthread.def $(DESTDIR)$(libdir)/gthread-2.0.def
@@ -71,7 +72,7 @@ libgthread_2_0_la_LDFLAGS = \
libgthread_2_0_la_LIBADD = $(G_THREAD_LIBS_EXTRA) $(G_THREAD_LIBS_FOR_GTHREAD) $(libglib)
-libgthread_2_0_la_DEPENDENCIES = $(gthread_win32_res) $(GTHREAD_DEF)
+libgthread_2_0_la_DEPENDENCIES = $(gthread_win32_res) $(gthread_def)
if OS_WIN32
gthread-win32-res.o: gthread.rc