summaryrefslogtreecommitdiff
path: root/gobject/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@linux.intel.com>2010-06-04 16:17:15 +0100
committerEmmanuele Bassi <ebassi@linux.intel.com>2010-06-15 16:06:18 +0100
commit6d1d9cf1b551845a159a6b822500bb40e33fda74 (patch)
tree44893244f94fe021fd5d35a2e72ac7009e4ac0bd /gobject/Makefile.am
parentf3879a4bdca2ff1cf6c6b016d67a7e5d40c0e86b (diff)
downloadglib-6d1d9cf1b551845a159a6b822500bb40e33fda74.tar.gz
gobject: Add GBinding
GBinding is a simple, opaque object that represents a binding between a property on a GObject instance (source) and property on another GObject instance (target). https://bugzilla.gnome.org/show_bug.cgi?id=348080
Diffstat (limited to 'gobject/Makefile.am')
-rw-r--r--gobject/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/gobject/Makefile.am b/gobject/Makefile.am
index 6bcd5ae01..c5be202b1 100644
--- a/gobject/Makefile.am
+++ b/gobject/Makefile.am
@@ -97,6 +97,7 @@ libgobject_2_0_la_DEPENDENCIES = $(gobject_win32_res) $(gobject_def)
#
# GObject library header files for public installation
gobject_public_h_sources = \
+ gbinding.h \
gboxed.h \
gclosure.h \
genums.h \
@@ -124,6 +125,7 @@ gobject_private_h_sources = \
gobject_c_sources = \
gobject_probes.d \
gatomicarray.c \
+ gbinding.c \
gboxed.c \
gclosure.c \
genums.c \
@@ -188,7 +190,7 @@ EXTRA_DIST += \
#
# setup autogeneration dependancies
gen_sources = xgen-gmh xgen-gmc xgen-gms
-CLEANFILES = $(gen_sources)
+CLEANFILES += $(gen_sources)
# normal autogeneration rules
# all autogenerated files need to be generated in the srcdir,
@@ -229,7 +231,6 @@ gmarshal.strings: @REBUILD@ $(srcdir)/gmarshal.list
glib-genmarshal.o: gmarshal.strings
gsignal.lo: gmarshal.c
-
# target platform:
libgobjectinclude_HEADERS = $(gobject_target_headers)
libgobject_2_0_la_SOURCES = $(gobject_target_sources)