summaryrefslogtreecommitdiff
path: root/gobject/Makefile.am
diff options
context:
space:
mode:
author21:06:47 Tim Janik <timj@imendio.com>2007-11-21 20:09:46 +0000
committerTim Janik <timj@src.gnome.org>2007-11-21 20:09:46 +0000
commit1e55738f31385ddb3bf172ba3590a79cf42782f4 (patch)
tree7fe6d77dc08924cce36731cfc2ed42295cf35df0 /gobject/Makefile.am
parent49568d5f163a661f1d52a25bd450a4c6ca5b3e18 (diff)
downloadglib-1e55738f31385ddb3bf172ba3590a79cf42782f4.tar.gz
initialize automake variables EXTRA_DIST and TEST_PROGS for unconditional
2007-11-21 21:06:47 Tim Janik <timj@imendio.com> * Makefile.decl: initialize automake variables EXTRA_DIST and TEST_PROGS for unconditional appending via += in other makefiles. define recursive test targets: test, test-report, perf-report, full-report, as described here: http://mail.gnome.org/archives/gtk-devel-list/2007-November/msg00000.html * Makefile.am: * build/win32/vs8/Makefile.am, build/win32/dirent/Makefile.am: * build/win32/Makefile.am, build/Makefile.am: * docs/Makefile.am, docs/reference/Makefile.am: * docs/reference/glib/Makefile.am, docs/reference/gobject/Makefile.am: * gmodule/Makefile.am, tests/Makefile.am: * tests/refcount/Makefile.am, tests/gobject/Makefile.am: * glib/update-pcre/Makefile.am, glib/libcharset/Makefile.am: * glib/tests/Makefile.am, glib/pcre/Makefile.am: * glib/gnulib/Makefile.am, gobject/Makefile.am, m4macros/Makefile.am: * gthread/Makefile.am, glib/Makefile.am: include $(top_srcdir)/Makefile.decl, adapted EXTRA_DIST assignments. * glib/tests/Makefile.am: removed example testing rules. * glib/tests/testing.c: conditionalized performance and slow tests. * glib/gtestutils.h: * glib/gtestutils.c: work around g_test_config_vars not changing its exported value after value assignments, aparently due to symbol aliases. * glib/gtester.c: fixed off-by-one error which produced junk in logs. * configure.in: check for python >= 2.4 and provide $PYTHON for scripts. svn path=/trunk/; revision=5914
Diffstat (limited to 'gobject/Makefile.am')
-rw-r--r--gobject/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gobject/Makefile.am b/gobject/Makefile.am
index 6721ed5d7..7dfb27689 100644
--- a/gobject/Makefile.am
+++ b/gobject/Makefile.am
@@ -2,6 +2,7 @@
# Copyright (C) 1997,98,99,2000 Tim Janik and Red Hat, Inc.
#
## Process this file with automake to produce Makefile.in
+include $(top_srcdir)/Makefile.decl
INCLUDES = \
-DG_LOG_DOMAIN=\"GLib-GObject\" \
@@ -142,7 +143,7 @@ gobject_extra_sources = \
gobject_target_headers = $(gobject_public_h_sources)
gobject_target_sources = $(gobject_c_sources)
EXTRA_HEADERS =
-EXTRA_DIST = \
+EXTRA_DIST += \
$(gobject_private_h_sources) \
$(gobject_extra_sources) \
makegobjectalias.pl \