summaryrefslogtreecommitdiff
path: root/gobject/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2004-11-23 17:56:58 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2004-11-23 17:56:58 +0000
commit0680744fbbe5d0c89a47ad042ea6a46ff09d15dd (patch)
tree76888fc6ecf76db84980a5495f3e7e527929bf3a /gobject/Makefile.am
parent1aa5b57737a225a2c897d22a4196125df3e0fe81 (diff)
downloadglib-0680744fbbe5d0c89a47ad042ea6a46ff09d15dd.tar.gz
Fix a problem with the PLT reduction changes which caused the internal
2004-11-23 Matthias Clasen <mclasen@redhat.com> Fix a problem with the PLT reduction changes which caused the internal aliases to lose all attributes. * glib/glib.symbols: Add attribute annotations. * glib/makegalias.pl: Keep attribute annotations, but strip PRIVATE. * glib/Makefile.am (glib.def): Strip attribute annotations, but keep PRIVATE.
Diffstat (limited to 'gobject/Makefile.am')
-rw-r--r--gobject/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gobject/Makefile.am b/gobject/Makefile.am
index 8e5261020..1318b9c19 100644
--- a/gobject/Makefile.am
+++ b/gobject/Makefile.am
@@ -14,7 +14,7 @@ INCLUDES = \
-DG_DISABLE_CONST_RETURNS
gobject.def: gobject.symbols
- (echo -e EXPORTS; cpp -P -DINCLUDE_VARIABLES -DINCLUDE_INTERNAL_SYMBOLS -DG_OS_WIN32 $(srcdir)/gobject.symbols | sed -e '/^$$/d' -e 's/^/ /' | sort) > gobject.def
+ (echo -e EXPORTS; cpp -P -DINCLUDE_VARIABLES -DINCLUDE_INTERNAL_SYMBOLS -DG_OS_WIN32 $(srcdir)/gobject.symbols | sed -e '/^$$/d' -e 's/^/ /' -e 's/G_GNUC_[^ ]*//' | sort) > gobject.def
gobjectalias.h: gobject.symbols
$(srcdir)/makegobjectalias.pl < $(srcdir)/gobject.symbols > gobjectalias.h