summaryrefslogtreecommitdiff
path: root/gmodule/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2017-07-16 16:41:02 +0200
committerChristoph Reiter <creiter@src.gnome.org>2018-01-04 22:21:40 +0100
commitcf93b27cebd067fd7b91a14e1cf1b2c17fcd9c97 (patch)
tree42e61a15e12cf74ff135deaefd9d0f87fd7e442e /gmodule/meson.build
parentaa7c5cbdcbe8b22f019c29668bcbe57d53f9866d (diff)
downloadglib-cf93b27cebd067fd7b91a14e1cf1b2c17fcd9c97.tar.gz
meson: fix static build under Windows
Properly define GLIB/GOBJECT_STATIC_COMPILATION when static build is enabled. Use library() instead of shared_library() to allow selecting static builds. https://bugzilla.gnome.org/show_bug.cgi?id=784995
Diffstat (limited to 'gmodule/meson.build')
-rw-r--r--gmodule/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/gmodule/meson.build b/gmodule/meson.build
index be1fff308..03c689e3a 100644
--- a/gmodule/meson.build
+++ b/gmodule/meson.build
@@ -95,7 +95,7 @@ if host_system == 'windows'
gmodule_sources += [gmodule_win_res]
endif
-libgmodule = shared_library('gmodule-2.0',
+libgmodule = library('gmodule-2.0',
sources : gmodule_sources,
version : library_version,
soversion : soversion,