summaryrefslogtreecommitdiff
path: root/gmodule/meson.build
diff options
context:
space:
mode:
authorMarco Trevisan (Treviño) <mail@3v1n0.net>2022-10-24 20:36:26 +0200
committerMarco Trevisan (Treviño) <mail@3v1n0.net>2022-10-26 17:39:25 +0200
commit98059d088fa74672a01999ea2105ea9442f05fb8 (patch)
treeddd964f75f7a1991ee085fc92cdc3a6dee16fea1 /gmodule/meson.build
parent4a33e2a17635113156cc46ac7b516ba192f5ad7b (diff)
downloadglib-98059d088fa74672a01999ea2105ea9442f05fb8.tar.gz
gmodule/meson: Use stdout to communicate return value pf dlsym test code
Diffstat (limited to 'gmodule/meson.build')
-rw-r--r--gmodule/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/gmodule/meson.build b/gmodule/meson.build
index b238e3f9f..3195fdc29 100644
--- a/gmodule/meson.build
+++ b/gmodule/meson.build
@@ -28,11 +28,11 @@ if g_module_impl == 'G_MODULE_IMPL_DL'
message('Building for MSVC: assuming that symbols are prefixed with underscore')
g_module_need_uscore = 1
elif meson.can_run_host_binaries()
- # FIXME: communicate result via stdout instead of return value, so non-0 return is not printed in bold red
rres = cc.run(dlopen_dlsym_test_code,
dependencies : libdl_dep,
name : 'dlsym() preceding underscores')
- if host_system == 'windows' or (rres.compiled() and rres.returncode() == 0)
+ if host_system == 'windows' or (rres.compiled() and
+ rres.returncode() == 0 and rres.stdout().to_int() == 0)
g_module_need_uscore = 1
endif
else