summaryrefslogtreecommitdiff
path: root/glib/meson.build
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2019-01-17 10:38:20 +0400
committerMarc-André Lureau <marcandre.lureau@redhat.com>2020-06-25 13:57:35 +0400
commitd83d68d64c40021be432416f9912ff9e59a337ce (patch)
tree1723b6e387b6dc70d82a9838aa9c3fd6dce70a90 /glib/meson.build
parent167b95012227bd6d8c50359ff7f3f4f648dc0803 (diff)
downloadglib-d83d68d64c40021be432416f9912ff9e59a337ce.tar.gz
guri: new URI parsing and generating functions
Add a set of new URI parsing and generating functions, including a new parsed-URI type GUri. Move all the code from gurifuncs.c into guri.c, reimplementing some of those functions (and g_string_append_uri_encoded()) in terms of the new code. Fixes: https://gitlab.gnome.org/GNOME/glib/issues/110 Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
Diffstat (limited to 'glib/meson.build')
-rw-r--r--glib/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/glib/meson.build b/glib/meson.build
index 3f24579b0..149d62f01 100644
--- a/glib/meson.build
+++ b/glib/meson.build
@@ -194,7 +194,7 @@ glib_sub_headers = files(
'gtypes.h',
'guuid.h',
'gunicode.h',
- 'gurifuncs.h',
+ 'guri.h',
'gutils.h',
'gvarianttype.h',
'gvariant.h',
@@ -283,7 +283,8 @@ glib_sources = files(
'gunibreak.c',
'gunicollate.c',
'gunidecomp.c',
- 'gurifuncs.c',
+ 'guri.c',
+ 'guriprivate.h',
'gutils.c',
'gutilsprivate.h',
'guuid.c',