summaryrefslogtreecommitdiff
path: root/gio/tests/meson.build
diff options
context:
space:
mode:
authorMarco Trevisan (Treviño) <mail@3v1n0.net>2022-10-25 18:45:46 +0200
committerMarco Trevisan (Treviño) <mail@3v1n0.net>2022-11-01 01:56:27 +0100
commited013f95500eeeefb57f86b4a5e82a80009b84ac (patch)
tree57c31bb94fe105c2b6f0a8f3650163054bacc43c /gio/tests/meson.build
parentff195b6e0dc2035ee51a2c273ea0b775fd53817e (diff)
downloadglib-ed013f95500eeeefb57f86b4a5e82a80009b84ac.tar.gz
gio/tests/meson: Make giomodule test to depend on built modules
These are loaded dynamically so we need to ensure they're available at test time
Diffstat (limited to 'gio/tests/meson.build')
-rw-r--r--gio/tests/meson.build12
1 files changed, 7 insertions, 5 deletions
diff --git a/gio/tests/meson.build b/gio/tests/meson.build
index be23bc525..1734d96d4 100644
--- a/gio/tests/meson.build
+++ b/gio/tests/meson.build
@@ -42,6 +42,10 @@ giotypefuncs_inc = custom_target(
input : gio_headers + [gioenumtypes_h] + gobject_install_headers,
command: [gengiotypefuncs_prog, '@OUTPUT@', '@INPUT@'])
+if glib_build_shared
+ subdir('modules')
+endif
+
# Test programs buildable on all platforms
gio_tests = {
'appmonitor' : {
@@ -66,7 +70,9 @@ gio_tests = {
'file-thumbnail' : {},
'fileattributematcher' : {},
'filter-streams' : {},
- 'giomodule' : {},
+ 'giomodule' : {
+ 'depends' : glib_build_shared ? [libtestmodulea, libtestmoduleb] : [],
+ },
'gsubprocess' : {
'suite': host_system == 'windows' ? ['flaky'] : [],
'extra_programs': ['gsubprocess-testprog'],
@@ -1037,7 +1043,3 @@ if installed_tests_enabled
endif
subdir('services')
-
-if glib_build_shared
- subdir('modules')
-endif