summaryrefslogtreecommitdiff
path: root/gio/tests/meson.build
diff options
context:
space:
mode:
authorMarco Trevisan (Treviño) <mail@3v1n0.net>2022-10-24 22:19:21 +0200
committerMarco Trevisan (Treviño) <mail@3v1n0.net>2022-11-01 01:56:10 +0100
commite1e4084ecba87de6db050f5c75877f1bf80ed467 (patch)
tree0e576b69958f5e055244255be424107d7a9ddcb9 /gio/tests/meson.build
parenta1a0a9d75a6d0c65c92479885a2dbe0e7aa779b7 (diff)
downloadglib-e1e4084ecba87de6db050f5c75877f1bf80ed467.tar.gz
gio/tests/meson: Add appinfo-test and apps as appinfo tests dependency
We need to make sure that such binaries are built and available at test time or we may fail some tests requiring them (directly or through desktop file). As per this, and because now generated desktop files are available both at build and install time, don't skip some tests we were used to, but actually enforce they are running.
Diffstat (limited to 'gio/tests/meson.build')
-rw-r--r--gio/tests/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/gio/tests/meson.build b/gio/tests/meson.build
index b0e280953..4ccf7f6e7 100644
--- a/gio/tests/meson.build
+++ b/gio/tests/meson.build
@@ -256,10 +256,12 @@ if host_machine.system() != 'windows'
gio_tests += {
'appinfo' : {
'install' : false,
+ 'extra_programs' : ['appinfo-test'],
},
'desktop-app-info' : {
'install' : false,
'depends' : gio_launch_desktop,
+ 'extra_programs' : ['apps', 'appinfo-test'],
},
}
endif