summaryrefslogtreecommitdiff
path: root/gio/tests/meson.build
diff options
context:
space:
mode:
authorMarco Trevisan (Treviño) <mail@3v1n0.net>2022-10-25 01:58:37 +0200
committerMarco Trevisan (Treviño) <mail@3v1n0.net>2022-11-01 01:56:27 +0100
commitcaf75d8f9c6398b60798cb6083ed857a6f5e8c27 (patch)
tree19c4c64b3a475e7e7c330bc8ce64b0505f9a3717 /gio/tests/meson.build
parent97b0e965773bb97aad3fd56a11a6df66696b5b2b (diff)
downloadglib-caf75d8f9c6398b60798cb6083ed857a6f5e8c27.tar.gz
gio/tests/meson: Add basic-application as prerequisite of gapplication
It's currently commented code, but in any case it's better to build it earlier
Diffstat (limited to 'gio/tests/meson.build')
-rw-r--r--gio/tests/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/gio/tests/meson.build b/gio/tests/meson.build
index 942835656..1f71ba3a8 100644
--- a/gio/tests/meson.build
+++ b/gio/tests/meson.build
@@ -402,7 +402,10 @@ if host_machine.system() != 'windows'
'extra_sources' : [extra_sources, gdbus_test_codegen_generated_min_required_2_64, gdbus_test_codegen_generated_interface_info],
'c_args' : ['-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_64'],
},
- 'gapplication' : {'extra_sources' : extra_sources},
+ 'gapplication' : {
+ 'extra_sources' : extra_sources,
+ 'extra_programs': ['basic-application'],
+ },
}
if not glib_have_cocoa