summaryrefslogtreecommitdiff
path: root/gio/tests/meson.build
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-11-14 13:01:47 +0000
committerPhilip Withnall <philip@tecnocode.co.uk>2022-11-14 13:01:47 +0000
commita9fa7589c63f621216032b30cbb94dc49a6b8d98 (patch)
treed026591a9616bbc9f1877461fcb9bce5bd02aac8 /gio/tests/meson.build
parent84284521b2a4e29ab31deb81e3d707be37ed351f (diff)
downloadglib-a9fa7589c63f621216032b30cbb94dc49a6b8d98.tar.gz
tests: Work around Meson bug with using exe_wrapper
Do not use can_run_host_binaries() as it returns true even though custom_target() does not currently correctly wrap target-built tool binaries with exe_wrapper so they can be run on the host. See https://github.com/mesonbuild/meson/issues/11029
Diffstat (limited to 'gio/tests/meson.build')
-rw-r--r--gio/tests/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/gio/tests/meson.build b/gio/tests/meson.build
index 04d7f4212..da4161766 100644
--- a/gio/tests/meson.build
+++ b/gio/tests/meson.build
@@ -700,7 +700,9 @@ if installed_tests_enabled
endforeach
endif
-if meson.can_run_host_binaries()
+# FIXME: Work around Meson not automatically using exe_wrapper around glib_compile_resources
+# https://github.com/mesonbuild/meson/issues/11029
+if not meson.is_cross_build()
resource_plugin = []
compiler_type = '--compiler=@0@'.format(cc.get_id())