summaryrefslogtreecommitdiff
path: root/gio/tests/meson.build
diff options
context:
space:
mode:
authorMarco Trevisan (Treviño) <mail@3v1n0.net>2022-12-15 21:40:35 +0100
committerMarco Trevisan (Treviño) <mail@3v1n0.net>2023-01-17 21:08:48 +0100
commit58031feb17659a8d24ff4e2eeebe70f10fcce5da (patch)
tree98e18bd0e2fda0db2d74fa84e0620f433c9bb873 /gio/tests/meson.build
parentf21772ead0bee82dc3e6deacfdbb811d61ee2b45 (diff)
downloadglib-58031feb17659a8d24ff4e2eeebe70f10fcce5da.tar.gz
meson: Use 'tap' test protocol by default
Meson supports tap protocol results parsing, allowing us to track better the tests that are running (and the ones that are actually skipped) without manually parsing the test output. However this also implies that using the verbose mode for a test doesn't show its output by default (unless there are failures).
Diffstat (limited to 'gio/tests/meson.build')
-rw-r--r--gio/tests/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/gio/tests/meson.build b/gio/tests/meson.build
index 13a1775ce..16478f69b 100644
--- a/gio/tests/meson.build
+++ b/gio/tests/meson.build
@@ -1035,6 +1035,7 @@ foreach test_name, extra_args : gio_tests
endif
test(test_name, exe,
+ protocol : extra_args.get('protocol', test_protocol),
env : local_test_env,
timeout : timeout,
suite : suite,
@@ -1059,6 +1060,7 @@ foreach test_name, extra_args : python_tests
test(
test_name,
python,
+ protocol : extra_args.get('protocol', test_protocol),
depends: depends,
args: ['-B', files(test_name)],
env: test_env,