summaryrefslogtreecommitdiff
path: root/gio/tests/meson.build
diff options
context:
space:
mode:
authorPhilip Withnall <pwithnall@endlessos.org>2022-11-16 15:52:09 +0000
committerPhilip Withnall <pwithnall@endlessos.org>2022-11-23 10:40:32 +0000
commit19353017a786e90e00c29890ba6ca2ef88798df4 (patch)
tree2c6b3b368c308e7fffbe53106ceade12e415b684 /gio/tests/meson.build
parent7e3e591d430e6576292379a4f2d94d5fc0656c36 (diff)
downloadglib-19353017a786e90e00c29890ba6ca2ef88798df4.tar.gz
build: Use fs.copyfile() instead of configure_file()
Because Meson complains about using `configure_file(copy: true)`. Includes improvements by Xavier Claessens. Signed-off-by: Philip Withnall <pwithnall@endlessos.org>
Diffstat (limited to 'gio/tests/meson.build')
-rw-r--r--gio/tests/meson.build25
1 files changed, 14 insertions, 11 deletions
diff --git a/gio/tests/meson.build b/gio/tests/meson.build
index da4161766..78b7f87b4 100644
--- a/gio/tests/meson.build
+++ b/gio/tests/meson.build
@@ -308,7 +308,8 @@ if host_machine.system() != 'windows'
input : ['test-codegen.xml'],
output : ['gdbus-test-codegen-generated.h',
'gdbus-test-codegen-generated.c'],
- depend_files : gdbus_codegen_built_files,
+ depends : gdbus_codegen_depends,
+ depend_files : gdbus_codegen_depend_files,
command : [python, gdbus_codegen,
'--interface-prefix', 'org.project.',
'--output-directory', '@OUTDIR@',
@@ -324,7 +325,8 @@ if host_machine.system() != 'windows'
input : ['test-codegen.xml'],
output : ['gdbus-test-codegen-generated-min-required-2-64.h',
'gdbus-test-codegen-generated-min-required-2-64.c'],
- depend_files : gdbus_codegen_built_files,
+ depends : gdbus_codegen_depends,
+ depend_files : gdbus_codegen_depend_files,
command : [python, gdbus_codegen,
'--glib-min-required', '2.64',
'--interface-prefix', 'org.project.',
@@ -340,7 +342,8 @@ if host_machine.system() != 'windows'
custom_target('gdbus-test-codegen-generated-interface-info-h',
input : ['test-codegen.xml'],
output : ['gdbus-test-codegen-generated-interface-info.h'],
- depend_files : gdbus_codegen_built_files,
+ depends : gdbus_codegen_depends,
+ depend_files : gdbus_codegen_depend_files,
command : [python, gdbus_codegen,
'--interface-info-header',
annotate_args,
@@ -349,7 +352,8 @@ if host_machine.system() != 'windows'
custom_target('gdbus-test-codegen-generated-interface-info-c',
input : ['test-codegen.xml'],
output : ['gdbus-test-codegen-generated-interface-info.c'],
- depend_files : gdbus_codegen_built_files,
+ depends : gdbus_codegen_depends,
+ depend_files : gdbus_codegen_depend_files,
command : [python, gdbus_codegen,
'--interface-info-body',
annotate_args,
@@ -457,7 +461,8 @@ if host_machine.system() != 'windows'
input : ['../org.freedesktop.portal.Documents.xml'],
output : ['fake-document-portal-generated.h',
'fake-document-portal-generated.c'],
- depend_files : gdbus_codegen_built_files,
+ depends : gdbus_codegen_depends,
+ depend_files : gdbus_codegen_depend_files,
command : [python, gdbus_codegen,
'--interface-prefix', 'org.freedesktop.portal.',
'--output-directory', '@OUTDIR@',
@@ -737,6 +742,9 @@ if not meson.is_cross_build()
output : ['gresource-big-test.txt'],
command : [python, '@INPUT0@', '@OUTPUT@'])
+ # referenced by test.gresource.xml
+ test_generated_txt = fs.copyfile('test1.txt', 'test-generated.txt')
+
test_gresource = custom_target('test.gresource',
input : 'test.gresource.xml',
output : 'test.gresource',
@@ -747,6 +755,7 @@ if not meson.is_cross_build()
'--sourcedir=' + meson.current_build_dir(),
'--internal',
'@INPUT@'],
+ depends: test_generated_txt,
install_dir : installed_tests_execdir,
install_tag : 'tests',
install : installed_tests_enabled)
@@ -816,12 +825,6 @@ if not meson.is_cross_build()
'--manual-register',
'@INPUT@'])
- # referenced by test.gresource.xml
- test_generated_txt = configure_file(input : 'test1.txt',
- output : 'test-generated.txt',
- copy : true,
- )
-
resources_extra_sources = [
test_gresource,
test_resources_c,