summaryrefslogtreecommitdiff
path: root/gio/tests/meson.build
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2023-03-31 20:17:56 +0200
committerJan Tojnar <jtojnar@gmail.com>2023-03-31 20:44:14 +0200
commit004f48f4fc8adfccad51e2a7f4608c7fe3c28c7c (patch)
tree0dd8044e428b01b6576747a6fdc065cdd870ce4d /gio/tests/meson.build
parent7fec23ed5e47992ae99c317b07733350280a3b84 (diff)
downloadglib-004f48f4fc8adfccad51e2a7f4608c7fe3c28c7c.tar.gz
build/gmodule-2.0.pc: Move compiler flags from Libs to Cflags
Previously, `-Wl,--export-dynamic` was in `Libs` key of `gmodule-2.0.pc`, even though `-Wl` is a compiler flag, rather than a linker one. This caused issues with API reference builds in evolution-data-server, which passes the output of `pkg-config --libs` through `--ldflags` argument of `gtkdoc-scan`, which are forwarded unchanged to `ld`: ld: unrecognized option '-Wl,--export-dynamic' Let’s move the flag to `Cflags` so that the compiler can deal with it. https://gitlab.gnome.org/GNOME/evolution-data-server/-/issues/463
Diffstat (limited to 'gio/tests/meson.build')
-rw-r--r--gio/tests/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/gio/tests/meson.build b/gio/tests/meson.build
index b4a64926e..27de852be 100644
--- a/gio/tests/meson.build
+++ b/gio/tests/meson.build
@@ -767,7 +767,7 @@ if not meson.is_cross_build()
resource_plugin += shared_module('resourceplugin',
sources: ['resourceplugin.c', plugin_resources_c],
- link_args : export_dynamic_ldflags,
+ c_args : export_dynamic_cflags,
dependencies : common_gio_tests_deps,
install_dir : installed_tests_execdir,
install_tag : 'tests',