summaryrefslogtreecommitdiff
path: root/fuzzing/meson.build
diff options
context:
space:
mode:
authorpdknsk <pdknsk@gmail.com>2019-03-13 11:47:36 +0000
committerPhilip Withnall <philip@tecnocode.co.uk>2019-03-13 11:47:36 +0000
commit92043cf077e33814a55cd1a77cae8eb57af3f6d1 (patch)
treeb98267101c4b071e2d6d7af39156ad677095d52d /fuzzing/meson.build
parent1a03ebc43ac1ef4b803fb324d809e88f52d54c0d (diff)
downloadglib-92043cf077e33814a55cd1a77cae8eb57af3f6d1.tar.gz
Introduce oss_fuzz feature option
Diffstat (limited to 'fuzzing/meson.build')
-rw-r--r--fuzzing/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/fuzzing/meson.build b/fuzzing/meson.build
index 16878fedf..7fdd8c909 100644
--- a/fuzzing/meson.build
+++ b/fuzzing/meson.build
@@ -13,7 +13,7 @@ extra_c_args = cc.get_supported_arguments('-Werror=unused-function')
# Links in a static library provided by oss-fuzz, else a standalone driver.
# https://github.com/google/oss-fuzz/blob/master/docs/new_project_guide.md#buildsh-script-environment
-fuzzing_engine = cxx.find_library('FuzzingEngine', required : false)
+fuzzing_engine = cxx.find_library('FuzzingEngine', required : get_option('oss_fuzz'))
if fuzzing_engine.found()
deps += fuzzing_engine
else