summaryrefslogtreecommitdiff
path: root/fuzzing/meson.build
diff options
context:
space:
mode:
authorPhilip Withnall <pwithnall@endlessos.org>2021-12-15 16:56:51 +0000
committerPhilip Withnall <pwithnall@endlessos.org>2021-12-16 11:26:03 +0000
commit06e282e50fb6db7192b815639a62efcaa8759786 (patch)
treecd8741dc1fa9e4566a2dcfc0ba87944d989f4036 /fuzzing/meson.build
parent4d6da4457a80fc2cea4d0e3a1f332107a28b067d (diff)
downloadglib-06e282e50fb6db7192b815639a62efcaa8759786.tar.gz
fuzzing: Add a fuzz test for parsing DNS records
Based on Patrick’s work to expose the parser for unit testing. See !2134. Signed-off-by: Philip Withnall <pwithnall@endlessos.org>
Diffstat (limited to 'fuzzing/meson.build')
-rw-r--r--fuzzing/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/fuzzing/meson.build b/fuzzing/meson.build
index c60dcf446..259c6d91d 100644
--- a/fuzzing/meson.build
+++ b/fuzzing/meson.build
@@ -11,6 +11,7 @@ fuzz_targets = [
'fuzz_network_address_parse',
'fuzz_network_address_parse_uri',
'fuzz_paths',
+ 'fuzz_resolver',
'fuzz_uri_escape',
'fuzz_uri_parse',
'fuzz_uri_parse_params',