summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 74b3c006..add86602 100644
--- a/meson.build
+++ b/meson.build
@@ -330,6 +330,9 @@ header_conf.set('HAVE_DTRACE', get_option('dtrace'),
description: 'Using dtrace probes')
header_conf.set('HAVE_PRINTF_ALTERNATIVE_INT', have_printf_alternative_int,
description: 'printf() accepts "%Id" for alternative integer output')
+header_conf.set('HAVE_OPEN_MEMSTREAM',
+ cxx.has_function('open_memstream', prefix : '#include <stdio.h>'),
+ description: 'open_memstream() is available')
if build_readline
header_conf.set('HAVE_READLINE_READLINE_H',
cxx.check_header('readline/readline.h', prefix: '#include <cstdio>',