summaryrefslogtreecommitdiff
path: root/installed-tests/js/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'installed-tests/js/meson.build')
-rw-r--r--installed-tests/js/meson.build10
1 files changed, 7 insertions, 3 deletions
diff --git a/installed-tests/js/meson.build b/installed-tests/js/meson.build
index 6db887d2..1e953ceb 100644
--- a/installed-tests/js/meson.build
+++ b/installed-tests/js/meson.build
@@ -203,9 +203,13 @@ endif
# during build should be run using dbus-run-session
dbus_tests = ['GDBus']
-if have_gtk4 and not get_option('skip_gtk_tests')
- # FIXME: find out why GTK4 tries to acquire a message bus
- dbus_tests += 'Gtk4'
+if not get_option('skip_gtk_tests')
+ have_gtk4 = dependency('gtk4', required: false).found()
+
+ if have_gtk4
+ # FIXME: find out why GTK4 tries to acquire a message bus
+ dbus_tests += 'Gtk4'
+ endif
endif
bus_config = files('../../test/test-bus.conf')