summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Young <chris@unsatisfactorysoftware.co.uk>2012-06-09 23:03:27 +0100
committerChris Young <chris@unsatisfactorysoftware.co.uk>2012-06-09 23:05:59 +0100
commit41cbbea8fe0aa56dc33027ba24249f69d831fe03 (patch)
tree3b5afcfdbc7cfa61bfc22b5d63c8516fa2058be4 /CMakeLists.txt
parent5c0fd7b976b8fb1271dbe61b9ea456672ab5b370 (diff)
downloadlibgit2-41cbbea8fe0aa56dc33027ba24249f69d831fe03.tar.gz
Let platform 'Generic' get the regex deps so we don't need to use our external ones
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 15 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 041553fd..2591fccb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,6 +41,10 @@ ENDIF()
IF (NOT WIN32)
FIND_PACKAGE(ZLIB)
+ IF (CMAKE_SYSTEM_NAME MATCHES "Generic")
+ INCLUDE_DIRECTORIES(deps/regex)
+ SET(SRC_REGEX deps/regex/regex.c)
+ ENDIF()
ELSE()
# Windows doesn't understand POSIX regex on its own
INCLUDE_DIRECTORIES(deps/regex)
@@ -54,7 +58,7 @@ ELSE (ZLIB_FOUND)
INCLUDE_DIRECTORIES(deps/zlib)
ADD_DEFINITIONS(-DNO_VIZ -DSTDC -DNO_GZIP)
FILE(GLOB SRC_ZLIB deps/zlib/*.c)
-ENDIF()
+#ENDIF()
# Installation paths
SET(INSTALL_BIN bin CACHE PATH "Where to install binaries to.")
@@ -62,7 +66,7 @@ SET(INSTALL_LIB lib CACHE PATH "Where to install libraries to.")
SET(INSTALL_INC include CACHE PATH "Where to install headers to.")
# Build options
-OPTION (BUILD_SHARED_LIBS "Build Shared Library (OFF for Static)" ON)
+OPTION (BUILD_SHARED_LIBS "Build Shared Library (OFF for Static)" OFF)
OPTION (THREADSAFE "Build libgit2 as threadsafe" OFF)
OPTION (BUILD_CLAR "Build Tests using the Clar suite" ON)
OPTION (BUILD_EXAMPLES "Build library usage example apps" OFF)
@@ -102,12 +106,15 @@ IF (NOT CMAKE_BUILD_TYPE)
SET(CMAKE_BUILD_TYPE "Debug" CACHE STRING "Choose the type of build, options are: Debug Release RelWithDebInfo MinSizeRel." FORCE)
ENDIF ()
-#FIND_PACKAGE(OpenSSL)
-#IF (OPENSSL_FOUND)
-# ADD_DEFINITIONS(-DGIT_SSL)
-# INCLUDE_DIRECTORIES(${OPENSSL_INCLUDE_DIR})
-# SET(SSL_LIBRARIES ${OPENSSL_LIBRARIES})
-#ENDIF()
+IF (CMAKE_SYSTEM_NAME MATCHES "Generic")
+ELSE ()
+ FIND_PACKAGE(OpenSSL)
+ IF (OPENSSL_FOUND)
+ ADD_DEFINITIONS(-DGIT_SSL)
+ INCLUDE_DIRECTORIES(${OPENSSL_INCLUDE_DIR})
+ SET(SSL_LIBRARIES ${OPENSSL_LIBRARIES})
+ ENDIF()
+ENDIF()
IF (THREADSAFE)
IF (NOT WIN32)