summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index eb27d4a..a9dd8b9 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -33,9 +33,14 @@ gf_inline_time_SOURCES = gf_inline_time.c
#gf_inline_time_LDFLAGS = -lgf_complete
gf_inline_time_LDADD = ../src/libgf_complete.la
+# gf_unit 8 A -1 -m LOG_ZERO_EXT is excluded until http://lab.jerasure.org/jerasure/gf-complete/issues/13 is resolved
+if ENABLE_VALGRIND
+VALGRIND = | perl -p -e 's|^|../libtool --mode=execute valgrind --quiet --error-exitcode=1 --tool=memcheck | if(!/gf_unit 8 A -1 -m LOG_ZERO_EXT/)'
+endif
+
# gf_unit tests as generated by gf_methods
gf_unit_w%.sh: gf_methods
- ./$^ $(@:gf_unit_w%.sh=%) -A -U > $@ || rm $@
+ ./$^ $(@:gf_unit_w%.sh=%) -A -U ${VALGRIND} > $@ || rm $@
TESTS = gf_unit_w128.sh \
gf_unit_w64.sh \