summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLoic Dachary <loic-test4@dachary.org>2016-09-13 19:23:39 +0000
committerLoic Dachary <loic-test4@dachary.org>2016-09-13 19:23:39 +0000
commit185295f247698f727fd3bb11c4795e1741bb359e (patch)
tree36827c435bb59800ad73a4a414b2ba00c4b8558f /configure.ac
parent51a1abb9185ec6ea35817620d13322047f4fde4d (diff)
parentf940bf3b5be7eec6fe3e38a11ab65592b1dc10db (diff)
downloadgf-complete-185295f247698f727fd3bb11c4795e1741bb359e.tar.gz
Merge branch 'wip-valgrind' into 'master'
enable valgrind for tests See merge request !9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ad7bb83..3e8cf18 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,5 +60,11 @@ AC_ARG_ENABLE([sse],
fi]
)
+AC_ARG_ENABLE([valgrind],
+ [AS_HELP_STRING([--enable-valgrind], [run tests with valgrind])],
+ [],
+ [enable_valgrind=no])
+AM_CONDITIONAL(ENABLE_VALGRIND, test "x$enable_valgrind" != xno)
+
AC_CONFIG_FILES([Makefile src/Makefile tools/Makefile test/Makefile examples/Makefile])
AC_OUTPUT