summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin Greenan <kmgreen2@gmail.com>2013-11-26 07:09:36 -0800
committerKevin Greenan <kmgreen2@gmail.com>2013-12-04 21:24:29 -0800
commit153dd20988bf9e91f10f8c5564f2c4d6a2fc50cd (patch)
tree68a886097544b001a26702db32ab4ea8583cea46 /configure.ac
parentbc2f7c1c3685cd086d82f48215f4a0ccdf716072 (diff)
downloadgf-complete-153dd20988bf9e91f10f8c5564f2c4d6a2fc50cd.tar.gz
Setting up autoconf/automake for GF-Complete
Also re-organized the directory structure. Signed-off-by: Kevin Greenan <kmgreen2@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..96c8f62
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,22 @@
+# gf-complete autoconf template
+
+# FIXME - add project url as the last argument
+AC_INIT(gf-complete, 1.0)
+
+AC_PREREQ([2.61])
+
+AM_INIT_AUTOMAKE(no-dependencies)
+LT_INIT # libtool
+
+AC_CONFIG_HEADER(include/config.h)
+
+dnl Needed when reconfiguring with 'autoreconf -i -s'
+AC_CONFIG_MACRO_DIR([m4])
+
+dnl Compiling with per-target flags requires AM_PROG_CC_C_O.
+AC_PROG_CC
+
+AX_EXT()
+
+AC_CONFIG_FILES([Makefile src/Makefile tools/Makefile test/Makefile examples/Makefile])
+AC_OUTPUT